X3P0 Legacy Widget

Contributors greenshady
Type Free
Current Version 1.0.0
Last Updated 28 Jun, 2022
Released 28 Jun, 2022
Total Download 198
Active Install 30
Support 0 out of 0

X3P0 Legacy Widget enables the core WordPress Legacy Widget block for the WordPress block editor. It is meant to be used alongside a block-based theme, such as Twenty Twenty-Two, so that users can embed classic widgets into their sites via the site editor (Appearance > Editor).

This plugin is mostly useful when working with third-party plugins that register custom widgets that have yet to be ported to the block system. This is meant to be a temporary fix, at least until developers update their plugins to support the block system. Please talk to your plugin developers and find out whether they have plans to do so in the long term. If not, you should look for alternative plugins that create block versions of the features you need. This plugin is meant as a transitioning tool, not something to rely on forever.

Note #1: The Legacy Widget block is a core WordPress (Gutenberg) block and not created by this plugin. For known issues or tickets related to the block itself, see the Legacy Widget label in the Gutenberg project repository.

Note #2: Widget options do not appear when used with the post/page editor. However, widget options are available via the site editor (Appearance > Editor). When used in a post/page, this means that users are stuck with whatever the widget’s default options are.

Note #3: Not all third-party widgets from plugins/themes will work in the editor. This is more likely an issue with those that use custom JavaScript. Please encourage plugin authors to migrate their plugins to custom block types.

0
0 Reviews
5
0%
4
0%
3
0%
2
0%
1
0%